Meta element NCC TotalTime corrupted 29,76815548:46:05


Hello Rachana

on January 2017 using OBI 3.9 we produced 1 of our first DTB with OBI (we started in Dec 2016). The paper book is so big it
is recorded on 2 CDs. Everything went well, we can listen the 2 parts, nop. We exported in DAISY 2.02 format. We created the
2 DTBs as 'individual' DTB.At that time we did not use the DAISY 2.02 Validation (because we did not know it at that period,
now we use it...;-) anyhow this is not the problem).

We then move these 2DTBs on a national (France) library for DTBs (BNFA) where thousands of DTBs reside...and we received a comment
from them telling us there is a problem with the NCC TotalTime meta element and they are right. They told us the DAISY reader device they
are using does not accept the DTBs.

The problem: could it be in the CD number 1 or the CD number 2 the TotalTime is 'corrupted':
DTB fr-giaa75-04967-01 in the NCC HTML meta name="ncc:totalTime" content="29,7681546674167:46:05"
DTB fr-giaa75-04967-01 in the MASTER SMIL meta name="ncc:timeInThisSmil" content="29,7681546674167:46:05"
DTB fr-giaa75-04967-02 in the NCC HTML meta name="ncc:totalTime" content="26,5242067649444:31:27"
DTB fr-giaa75-04967-02 in the MASTER SMIL meta name="ncc:timeInThisSmil" content="26,5242067649444:31:27"
Up to the last SMIL files where we do not have that strange time format, the TotalTime duration is below 24h like here:
DTB fr-giaa75-04967-01 in the 056 SMIL
meta name="ncc:totalElapsedTime" content="20:33:03.1411566"
meta name="ncc:timeInThisSmil" content="03:38:59.2007029"
then in the 057 SMIL

Few questions:
Q1: is there a 'limitation' on the Totaltime duration ? I mean, the fact the 'problem' appears just at the transition 24h is probably not a
coincidence ?
Q2: using OBI 391 this morning, I imported the DTBs and exported in DAISY 2.02 and the same, the TotalTime is 'corrupted'. I then run the DAISY
2.02 Validation and all is fine, no error message displayed or no line added in a file I selected as beging the validation log.

Comment: in France the decimal separator is a comma ( , ) and NOT the dot ( .). On the workstation we use here to produce the DTBs with OBI
(or with PLEXTALK) the decimal separator in Windows is indeed set to a comma. I do not know if this is important.

I am going to send you the 2 DTBs via a Dropbox, so that you can have a look.

Thanks for your help

Please change settings in your computer to use dot(.) as the separator instead of the comma.

This should solve the problem as of now.

Hi Eric

DAISY standard insist on using'.' instead of ',' irrespective of the language of DTB.
. This problem appears in languages where ',' replaces '.'. Obi takes care of this issue, but it looks that when time overflows over 24 hours, then this problem appears. You can do the setting suggested by Prashant and export again, or you can just remove the numbers after ',' in your files
for example content="29,7681546674167:46:05"
should be replaced by content="29:46:05"

We will fix this issue of 24 hrs timing in next release

With regards

Bonjour Avneesh, thanks for this. I think I will remove the numbers after and will do a checking next week (I am off for a week).


Avneesh, just to be sure we have covered all aspects of this TotalTime meta data: when I ran the OBI 391 DAISY 2.02 validator, I received no error or warning messages
related to this ncc:totalTime" content="29,7681546674167:46:05 . Is it 'normal' ? Is the OBI validator checking this meta data ? The reason I am asking is that we were alerted
by users having run a DAISY 2.02 validator (I do not know what software/device they use) which detected the problem. The BNFA librarian after the alert ran the DAYSY Pipeline
validator which seemed to help determining the problem.


For validation, Obi uses Pipeline in backend. It is lighter version, named Pipeline-lite, it has limited number of Pipeline scripts that are important for Obi

It is a good feedback for us, we will check if this problem is specific to DAISY 2.02 balidater in Pipeline-lite

You can also download Pipeline 1 and check if it gives better results

With regards