Pipeline2 1.8 on Ubuntu 14 defunct

Forums: 

I can't make Pipeline2 work on Ubuntu 14. (I've tried on debian with the same results.)

Here is what I do:

$ java -version
java version "1.7.0_65"
OpenJDK Runtime Environment (IcedTea 2.5.3) (7u71-2.5.3-0ubuntu0.14.04.1)
OpenJDK 64-Bit Server VM (build 24.65-b04, mixed mode)
$ ruby -v
ruby 1.9.3p484 (2013-11-22 revision 43786) [x86_64-linux]
$ wget -q https://github.com/daisy/pipeline-assembly/releases/download/v1.8/pipeline2-1.8-webui-desktop.zip
$ unzip pipeline2-1.8-webui-desktop.zip
$ daisy-pipeline/cli/dp2
[DP2] Waiting for the WS to come up
<>
[ERROR] WS is not up and I have been waiting for 60.059999999999775 s

Please help. I'm really stuck!

Can you try with version 1.8.1 and let me know if it works ?

If not, can you run:

$ daisy-pipeline/bin/pipeline2

and send me the log via email to rdeltour(at)gmail(dot)com ?

Romain.

Thanks for your reply!

I am away from work and won't be able to try with version 1.8.1, but I tried to locate this verison.

If I open http://www.daisy.org/pipeline2, this page says that the latest version is version 1.8 and the "download now" link leads to

https://github.com/daisy/pipeline-assembly/releases/tag/v1.8

I can see that if append a ".1" to the URL above, I get version 1.8.1. I guess that is the one. Who is in charge of the home page?

When I get back to work, I'll try the newer version. Thanks for the pointer.

I got access to a docker container at work. It is not entirely debian, but very close. The result is the same.

Also, running pipeline2 as you describe yields the following:

$ daisy-pipeline/bin/pipeline2
pipeline2: JAVA_HOME not set; results may vary

No further output.

The directory daisy-pipeline/data only contains felix-cache. There is no log directory.

I am running everything as the same user (root), so there shouldn't be any problems with permissions.

I can see that pipeline2 is running, but the process is just hanging. As far as I can tell, it never gets to produce any log output.

It seems that this forum some times leaves out the body.

As I tried to write in the above:

Thanks for updating the link on the download page.

Is there anything else I can provide to help debugging the error that I experience?

I tried to trace the process, and it seems to be polling some shared memory forever.

Can you try to set JAVA_HOME to the path to your Java installation ? (the one that contains the bin directory).

Strange forum errors indeed :( I'll report to our web admins.

It does work well with OpenJDK too, it's just a matter of finding the right place for JAVA_HOME. It should be something along the lines of export JAVA_HOME=/usr/lib/jvm/java-7-openjdk-amd64 (depending on which version of Java and OS architecture).

Anyway, glad that you got it working with Oracle JDK !