Pipeline 2 will not run on Windows7

Forums: 

I write with a heavy heart, having written a detailed post yesterday which seems to have gone into the ether. If anyone can help me to get Pipeline 2 working I would be most grateful.
So far as I can tell, all system requirements are met. When running the Pipeline, I receive the message that it is taking a long time and I either have a slow machine or there is a problem. A copy of the log file is attached - I read errors but their meaning is well beyond me. If I run the Pipeline again the message says that it appears to be already running.

Andrew

Dear Andrew,

We've been reported issues with running the latest Pipeline version on Windows, especially when a previous version was installed.

Can you please make sure that:

  • you uninstalled any previously installed version of the Pipeline 2 (from the Add/Remove Programs window)
  • or alternatively, manually delete the Pipeline's home directory, as well as local settings in C:\Users\<yourname>\AppData\Roaming\DAISY Pipeline 2
  • make sure no Pipeline-related java process is running, you can look for and kill such "ghost" using the Task Manager tool on Windows.

Let me know if that works!

Romain, thank you very much for suggestions. I have done a full uninstall and reinstall, ensuring that all files were removed. I am still getting the same error. What seems to me to be the most relevant contents of the log file is pasted:

2014-01-13 12:19:59,153 - [INFO] - from play in main
database [derby] connected at jdbc:derby:C:\Users\ADOWNIE\AppData\Roaming\DAISY Pipeline 2/webui/dp2webui

2014-01-13 12:20:05,234 - [INFO] - from application in main
STARTING....

2014-01-13 12:20:05,254 - [INFO] - from application in main
Using as uploaded files directory: C:\Users\ADOWNIE\AppData\Local\Temp\daisy-pipeline-webui-5747644664990663914.tmp\uploads\

2014-01-13 12:20:05,647 - [INFO] - from play in main
Starting application default Akka system.

2014-01-13 12:20:05,697 - [INFO] - from application in application-akka.actor.default-dispatcher-3
Running command 'cmd /c start /B pipeline2.bat' from directory 'C:\Program Files (x86)\DAISY Pipeline 2\daisy-pipeline\webui\..\bin'

2014-01-13 12:20:05,717 - [INFO] - from play in main
Application started (Prod)

2014-01-13 12:20:07,188 - [INFO] - from application in Thread-9
[Pipeline 2 Engine console output] Error occurred during initialization of VM

2014-01-13 12:20:07,188 - [INFO] - from application in Thread-9
[Pipeline 2 Engine console output] Could not reserve enough space for object heap

2014-01-13 12:20:07,188 - [ERROR] - from application in Thread-10
[Pipeline 2 Engine console output] Error: Could not create the Java Virtual Machine.

2014-01-13 12:20:07,198 - [ERROR] - from application in Thread-10
[Pipeline 2 Engine console output] Error: A fatal exception has occurred. Program will exit.

2014-01-13 12:20:07,298 - [INFO] - from play in main
Listening for HTTP on /0:0:0:0:0:0:0:0:9000

2014-01-13 12:20:52,658 - [WARN] - from application in play-akka.actor.default-dispatcher-5
Could not delete user 5 (Administrator / email@example.com)
javax.persistence.OptimisticLockException: Data has changed. updated [0] rows sql[delete from users where id=? and email=? and name=? and password=? and admin=? and active=? and password_link_sent is null] bind[null]

One issue I should have mentioned earlier: the machine is behind a firewall with authenticated proxy. Does the Pipeline require access to the internet to work and, if so, is it likely to be affected by a system that requires authentication with username and password?

Thanks again

Andrew

Incidentally, I am appalled at the introduction of CAPTCHA on this forum. I can't read the visual characters and nothing happens when I select audio. Given that one has to log in to post, this seems unnecessary at best and discriminates against vision impaired people.

When I tried submitting again my message was accepted. Very confusing :)

Andrew