Draft Standard for Trial Use review period begins

Development of the Z39.86 Authoring and Interchange Framework Specification has reached the stage where the Working Group believe it is ready for test use as the final step before presenting to NISO for certification. Your assistance in evaluating the specification for its completeness and usability is consequently requested at this time.

The review period begins Monday, March 28, 2011 and runs until Wednesday, September 28, 2011.

All issues should be reported in the Issue Tracker at http://code.google.com/p/zednext/issues/list

For general comments and questions, please use the DAISY Contact Form (select the category Standards): http://www.daisy.org/contact

For additional information, please see the Request for Reviewers at http://www.daisy.org/zw/ZedAI_Request_for_Reviewers

Hi,

Is there any software that converts DTB XML to Z39.86-2011 format?

Thanks
Sunny

Also, is there any DTD/Schema available for download to prepare Z39.86-2011 document

For documentation on Z39.86-2011 (also known as "ZedAI" or "DAISY 4 XML"):
http://www.daisy.org/z3986/2011/

For DTBook to ZedAI (book profile) conversion, you can try the Pipeline 2 project (only available as a command line tool at the moment):
http://www.daisy.org/pipeline2/

Romain.

Hello,

Thank you for sharing the information. I have downloaded the Pipeline 2 project and I got the following error message when I tried to convert a DTB XML to ZEDAI XML:

2011-11-28 13:40:16,733 [INFO ] org.daisy.pipeline.logging.Activator - earlyStartup slf4j SLF4JBridgeHandler...
2011-11-28 13:40:23,481 [ERROR] o.d.p.ui.commandline.PipelineCLI - null
java.lang.IllegalArgumentException: null
at java.net.URI.create(Unknown Source) ~[na:1.6.0]
at java.net.URI.resolve(Unknown Source) ~[na:1.6.0]
at org.daisy.common.xproc.calabash.DynamicXProcConfigurationFactory.loadConfigurationFile(DynamicXProcConfigurationFactory.java:85) ~[na:na]
at org.daisy.common.xproc.calabash.DynamicXProcConfigurationFactory.newConfiguration(DynamicXProcConfigurationFactory.java:36) ~[na:na]
at org.daisy.common.xproc.calabash.CalabashXProcPipeline$1.get(CalabashXProcPipeline.java:49) ~[na:na]
at org.daisy.common.xproc.calabash.CalabashXProcPipeline$1.get(CalabashXProcPipeline.java:1) ~[na:na]
at org.daisy.common.xproc.calabash.CalabashXProcPipeline.run(CalabashXProcPipeline.java:126) ~[na:na]
at org.daisy.pipeline.ui.commandline.CommandPipeline.execute(CommandPipeline.java:89) ~[na:na]
at org.daisy.pipeline.ui.commandline.PipelineCLI$1.run(PipelineCLI.java:76) ~[na:na]
Caused by: java.net.URISyntaxException: Illegal character in opaque part at index 2: d:\daisy-pipeline\etc\conf_calabash.xml
at java.net.URI$Parser.fail(Unknown Source) ~[na:1.6.0]
at java.net.URI$Parser.checkChars(Unknown Source) ~[na:1.6.0]
at java.net.URI$Parser.parse(Unknown Source) ~[na:1.6.0]
at java.net.URI.(Unknown Source) ~[na:1.6.0]
... 9 common frames omitted

Thanks in advance
Sunny

Sunny,

Please create dedicated threads (use the "Post new forum topic" link) when starting discussions or support requests which are not related to the original topic. This will help the admins to maintain the forums.

For Pipeline 2 topics and support, the dedicated forum is:
http://www.daisy.org/forums/pipeline2

Regarding the error you got with the Pipeline 2 CLI, can you please show the full command line you tried ? You can create a follow-up thread in the Pipeline 2 forum.

Thank you, Romain.