Pipeline failing on PPC Macs

Forums: 
I have been able to confirm that the TTS Narrator in the latest Pipeline will fail in a PPC Mac running either 10.5 or 10.5 the failure happens at the very first TTS phrase, the title of the book. No further processing is done after that. Other scripts work as expected and Pipeline TTS Narrator works fine in Intel based Macs. I have now been able to confirm this problem on four separate Macs. Gregory Kearney Manager - Accessible Media Association for the Blind of Western Australia 61 Kitchener Avenue, PO Box 101 Victoria Park 6979, WA Australia Telephone: +61 (08) 9311 8202 Telephone: +1 (307) 224-4022 (North America) Fax: +61 (08) 9361 8696 Toll free: 1800 658 388 (Australia only) Email: gkearney@gmail.com

Greg and I had a joint test session and we found the solution: It turned out that the SoX audio converter tool provided in the Pipeline tools installer couldn't properly convert audio files from AIFF to WAV. The Pipeline requires SoX version 14.0.1 or newer. If you face the same problem, please install a newer version of SoX via either MacPorts or pre-built packages such as Rudix. Romain.

I have posted the two installer needed to make the Pipeline run under PPC at the links below. You should first install Pipeline and the tools installer as normal then run these two installers. This requires that you run system 10.5 or better. Sox 14.0.1 libpng 1.2.35 Gregory Kearney Manager - Accessible Media Association for the Blind of Western Australia 61 Kitchener Avenue, PO Box 101 Victoria Park 6979, WA Australia Telephone: +61 (08) 9311 8202 Telephone: +1 (307) 224 4022 (North America) Fax: +61 (08) 9361 8696 Toll free: 1800 658 388 (Australia only) Email: gkearney@gmail.com